您的位置:首页>>安全防范
关于Linux Polkit 权限提升漏洞的风险预警提示

 [ 发布时间:22/03/22    来源:    查看次数:1207 ]

【漏洞描述

近日,监测到Linux Polkit存在权限提升漏洞,漏洞编号CVE-2021-4034攻击者可利用该漏洞从普通权限提升至root权限,因Polkit为系统预装工具,主流Linux发行版本均受影响。

参考链接 https://www.openwall.com/lists/oss-security/2022/01/25/11

pkexec是一Linuxsetuid工具,用于授权用户在预定的策略下以其他用户身份执行命令,因该工具命令行参数处理不当,该漏洞允许攻击者通过控制环境变量引发pkexec执行任意代码,从而获取目标系统root权限。目前,漏洞POC已被泄露,攻击者利用该漏洞可导致恶意用户权限提升等危害。

严重等级:高危

【影响范围】

20095polkitpkexec创建以来主流的Linux版本均受该漏洞影响

【修复建议】

建议使用了Linux的用户尽快排查是否受影响,并升级到安全版本或更高版本。

目前主流Linux发行版本已发布安全补丁,建议用户尽快安装相关补丁或参照官方缓解措施进行处置,相关补丁参考:

Redhathttps://access.redhat.com/security/cve/CVE-2021-4034 

Debainhttps://security-tracker.debian.org/tracker/CVE-2021-4034 

Ubuntuhttps://ubuntu.com/security/CVE-2021-4034 

临时缓解措施:可删除pkexecSUID-bit权限来缓解该漏洞风险,执行命令如下:

# chmod 0755 /usr/bin/pkexec

  版权所有:海南外国语职业学院 网络信息中心                          
Copyright (C) 2015 Hainan College Of Foreign Studies